Skip to end of metadata
Go to start of metadata

Ice 3.6.3 is supported on the platform, compiler, and environment combinations shown below. Other platforms and compilers might work as well but have not been tested.

On this page:

Ice for C++

PlatformCompilerArchitecture

Windows 7
Windows 8.1
Windows 10
Windows Server 2008 R2
Windows Server 2012

Visual Studio 2012, Visual Studio 2013, Visual Studio 2015

x86, x64

Red Hat Enterprise Linux 6
Red Hat Enterprise Linux 7
Amazon Linux 2016.09
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server 12
Ubuntu 14.04 (Trusty Tahr)
Ubuntu 16.04 (Xenial Xerus) 

GCC 4.4
GCC 4.8
GCC 4.8
GCC 4.3
GCC 4.8
GCC 4.8
GCC 5.3

i686, x86_64
i686, x86_64
x86_64
i586, x86_64
x86_64
i386, amd64
amd64

OS X 10.11 El Capitan
macOS 10.12 Sierra

Xcode 7.3, Xcode 8
Xcode 8

x86_64
x86_64 

Ice for Java

PlatformEnvironment
All Ice for C++ platformsJDK 1.7, JDK 1.8
Android 4.2 or later

JDK 1.7, JDK 1.8, Android Studio

Ice for .NET

PlatformCompilerArchitecture

Windows 7
Windows 8.1
Windows 10
Windows Server 2008 R2
Windows Server 2012

Visual Studio 2012, Visual Studio 2013, Visual Studio 2015

x86, x64

Ice for Universal Windows Platform (UWP)

PlatformCompilerArchitecture
Windows 10Visual Studio 2015 (C++ only)x86, x64

Ice for WinRT

PlatformCompilerArchitecture
Windows 8.1Visual Studio 2013 (C++ only)x86, x64

Ice for PHP

PlatformEnvironmentArchitecture

Windows 7
Windows 8.1
Windows 10
Windows Server 2008 R2
Windows Server 2012

PHP 5.6x86
Red Hat Enterprise Linux 6
Red Hat Enterprise Linux 7
Amazon Linux 2016.09
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server 12
Ubuntu 14.04 (Trusty Tahr)
Ubuntu 16.04 (Wily Werewolf) 
PHP 5.3
PHP 5.4
PHP 5.3
PHP 5.3
PHP 5.5
PHP 5.5
PHP 7.0
i686, x86_64
i686, x86_64
x86_64
i586, x86_64
x86_64
i386, amd64
amd64 
OS X 10.11 El Capitan
macOS 10.12 Sierra 

PHP 5.5
PHP 5.6 

x86_64
x86_64

Ice for Python

PlatformEnvironmentArchitecture

Windows 7
Windows 8.1
Windows 10
Windows Server 2008 R2
Windows Server 2012

Python 2.7, Python 3.4, Python 3.5

x86, x64

Red Hat Enterprise Linux 6
Red Hat Enterprise Linux 7
Amazon Linux 2016.09
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server 12
Ubuntu 14.04 (Trusty Tahr)
Ubuntu 16.04 (Xenial Xerus)  

Python 2.6, Python 2.7, Python 3.4, Python 3.5

i686, x86_64
i686, x86_64
x86_64
i586, x86_64
x86_64
i386, amd64
amd64

OS X 10.11 El Capitan
macOS 10.12 Sierra
Python 2.7, Python 3.4, Python 3.5
 
x86_64

Ice for Ruby

PlatformEnvironmentArchitecture

Windows 7
Windows 8.1
Windows 10
Windows Server 2008 R2
Windows Server 2012

Ruby 2.3x86, x64
Red Hat Enterprise Linux 6
Red Hat Enterprise Linux 7
Amazon Linux 2016.09
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server 12
Ubuntu 14.04 (Trusty Tahr)
Ubuntu 16.04 (Xenial Xerus)  
Ruby 1.8 to Ruby 2.3

i686, x86_64
i686, x86_64
x86_64
i586, x86_64
x86_64
i386, amd64
amd64 
OS X 10.11 El Capitan
macOS 10.12 Sierra 
Ruby 2.0 to Ruby 2.3x86_64

Ice for JavaScript

PlatformEnvironment
Web browserRecent versions of Internet Explorer, Chrome, Firefox, Safari

Windows 7
Windows 8.1
Windows 10
Windows Server 2008 R2
Windows Server 2012
Ubuntu 14.04 (Trusty Tahr)
Ubuntu 16.04 (Xenial Xerus) 
OS X 10.11 El Capitan
macOS 10.12 Sierra 

Node.js 0.10, Node.js 0.12, Node.js 4.0, Node.js 5.x Node.js 6.x
  • No labels