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Writing an Ice Application with C-Sharp

This page shows how to create an Ice application with C#.

On this page:

Compile your Slice File

Write and Compile your Client
Run your Client and Server

Write and Compile your Server

Create Projects for your Client and Server Applications

Create Projects for your Client and Server Applications

We create two projects, one for the Server application and one for the Client application. These are regular Console projects with very little Ice-

specific additions.

.NET Framework 4.5 with Visual Studio

Open Visual Studio and create a new Console Application

New Project

b Recent [.NET Framework 4,61 | Sort by: | Default
4 |nstalled -
k] Blank App (Universal Windows) Visual C#
4 Visual C& e
Windows Universal WPF App (.MET Framework) Visual C#
Windows Classic Desktop “’c“
I Web D Windows Forms App (.NET Framewaork) Visual C#
MET Core
NET Standard Oﬁ Consale App (MNET Core) Visual C#
Cloud =
Extensibility Console App (.NET Framewark) Visual C#
Test e
I+ Visual Basic Esi! Class Library (\NET Standard) Visual C=
b Visual C++ o
I Visual F# ;E[Si! Class Library (MET Framework) Visual C2
SCL Server
I+ JavaScript @ ASP.MET Core Web Application Visual C#
I Python
I Other Project Types @ﬁ ASP.MET Web Application (NET Framework) Visual C#
? Online j Shared Project Visual C#
C#
E&! Class Library (Legacy Portable) Visual C#
Mot finding what you are lecking for? "
Open Visual Studic Installer ..E[Si! Class Library (Universal Windows) Visual C#
Name: Server
Location: [ C:\Userst ppgut\ DocumentsiManual,
Solution name: printer

ry

Search (Ctrl+E)

Type: Visual C#

A project for creating a command-line
application

Browse...

Create directory for solution
D Create new Git repository

Cancel

Create the client project using "File > Add > New Project..."
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Add New Project

I Recent [.NET Framework 4.6.1 | Sort by: | Default
4 |nstalled - -
B] Blank App (Universal Windows) Visual =
4 Visual C& iw
Windows Universal WPF App (.MET Framework) Visual C#
Windews Classic Desktop -
I Web Windows Forms App (.MET Framework) Visual C#
MET Core
MET Standard Console App ((NET Core) Visual C#
Cloud
Extensibility sole App (.MET Framework) Visual C#
Test
b Visual Basic Class Library (.MET Standard) Visual C2
I Visual C++
b Vizual F= Class Library (\NET Framewark) Visual C=
S0L Server
I+ JavaScript ASP.MET Core Web Application Visual C#
I Python
- ASP.NET Web Application (NET Framework) Visual C#
nline
FC“ . . )
J Shared Project Visual C#
Ci#
Eﬁi! Class Library (Legacy Portable) Visual C2
C#
E[‘ﬁ! Class Library (Universal Windows) Visual C=
Net finding what you are locking for? c* ) . i ) ) _
) i ni! Windows Runtime Component (Universal Windows) Visual C=
Open Visual Studic Installer 53 —
MName: Client
Location: [ C:\Users' ppgut\DocumentsiManual\printer -

Search (Ctrl+E)

Type: Visual C&

A project for creating a command-line
application

Browse...

Cancel

Add the zer oc. i cebui | der. nsbui | d and zer oc. i ce. net NuGet package to the projects with the NuGet Package Manager, found in "Tools >
NuGet Package Manager > Manage NuGet Packages for Solution...".

Browse

Installed Updates Consolidate

x[-] © [ include prerelease

zeroc.ice.net @ by ZeroC, 188K downloads
The Ice framework provides everything you need to build networked applications, including RPC, pub/sub, server deployment, and
more.

zeroc.ice.v140 & by ZeroC, 26.4K downloads
Ice C++ SDK for Visual Studio 2015 (v140). The Ice framework provides everything you need to build networked applications, including
RPC, pub/sub, server deployment, and more.

zeroc.ice.v141 @ by ZeroC, 25.9K downloads
Ice C++ SDK for Visual Studio 2017 (v141). The Ice framework provides everything you need to build networked applications, including
RPC, pub/sub, server deployment, and more.

zeroc.ice.v142 @ by 7ZeroC, 17K downloads
Ice C++ SDK for Visual Studio 2019 (v142). The Ice framework provides everything you need to build networked applications, including
RPC, pub/sub, server deployment, and more.

zeroc.ice.v120 & by ZeroC, 15K downloads
Ice C++ SDK for Visual Studio 2013 (v120). The Ice framework provides everything you need to build networked applications, including
RPC, pub/sub, server deployment, and more.

zeroc.ice.v100 @ by ZeroC, 10.8K downloads
Ice C++ SDK for Visual Studio 2010 (v100). The Ice framework provides everything you need to build networked applications, including
RPC, pub/sub, server deployment, and more.

Each package is licensed to you by its owner. NuGet is not responsible for, nor does it grant any licenses to, third-party packages.

7] Don't show this again

3.7.10

37.10

37.10

3.7.10

3.7.10

3.7.10

'S

Versions - 0

S zerocice.net @

NuGet - Solution = X

Manage Packages for Solution

Package source:

® nugetorg

Project

Client

Server

Installed

Installed: |not instaled |[ uninsta

Version: | Latest stable 3.7.10

Install

@ Package source mapping is off. Configure

@ Options

Description

The Ice framework provides everything you need to build networked
applications, including RPC, pub/sub, server deployment, and more.

Version:

37.10
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.NET 6.0
Open a new Command Prompt a run the following command to create the server and client projects:

dot net new console -0 Server

This generates a new .NET Core console application project in the Ser ver directory.

Then add references to the zer oc. i cebui | der. msbui | d and zer oc. i ce. net NuGet packages to this project:

dotnet add Server package zeroc.icebuilder.nsbuild
dotnet add Server package zeroc.ice. net

Finally, repeat these steps for the client project:

dotnet new console -o dient
dotnet add Cient package zeroc.icebuilder.nsbuild
dotnet add Cient package zeroc.ice. net

Compile your Slice File

The next step is to add the Slice file (Pri nt er . i ce) created earlier to each project, and then compile this Slice file.

800px

.NET Framework 4.5 with Visual Studio
Open the "Project > Add Existing Iltem" dialog and add Pri nt er. i ce to your Project:
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ﬂ_l printer - Microsoft Visual Studic

File Edit View Project Build Debug Team Tocls Test Analyze Window Help
o - |iﬁv" m| - = | Debug ~| AnyCPU ~ Server

Printer.cs &
= *% Client.Program

wor

+ | @ Main(string[] args)

&7 | Quick Launch (Ctrl+Q) P - B x

Jose Gutierrez de la Concha ~

Selution Explorer > Ix
@E-|o-5¢ T

P~

Search Solution Explorer (Ctrl+;)

ud 04 Add Existing Item - Client

¥0q|oo]  Ja10|dx3 1BA1G
W

R

» ThisPC » Documents » Manual » printer

RN

Organize ~ MNew folder

¥ Downloads # *  Name

client s
csharp Client
printer packages
test Server

D Printer.ice

o4 Microsoft Visual S T8 printer.sin

Projects
2% Dropbox
@@ OneDrive
O This PC
- 3D Objects

[ Desktop

| Documents v

Date modified

2220171145 ...

v 0 Search printer
Type

File folder

File folder

File folder
2017 12:06 ...

17 4:16 PM

File folder
ICE File

Microsoft Visual S...

File name: | Printerice

v‘ Al Files (=.%)

|v Cancel

Show output from:  Build - | ‘ ‘ = | a
Build started: Project: Server, Configuration: Debug Any CPU

-- Build started: Project: Client, Configuration: Debug Any CPU

Add
Add As Link

Client -> C:\Users\ppgut\DocumentsiManualiprinter\Client\bin\Debug\Client.exe
Server -» Ci\Users\ppgut\Documents\Manual\printer\Server\bin\Debug\Server.exe

= Build: 2 succeeded, @ failed, @ up-to-date, @ skipped ===

AR Output

R Solution 'printer’ (2 projects)

E
b Properties
P =W References
¥ App.config
¥ packages.config
b ©* Program.cs
4 Server
b Properties
P =B References
4 generated
b ©* Printer.cs
¥ App.config
¥ packages.config
[& Printerice
P ©* Program.cs

Seolution Explorer [EETESTILIES

4 Add to Source Control «

If the Ice Builder for Visual Studio is installed, it immediately generates the file gener at ed\ Pri nter. cs from Pri nt er. i ce unless you disabled au

tomatic building in the Ice Builder.

If you have automatic building disabled, select Bui | d to build your project. The build generates gener at ed\ Pri nter.cs fromPrinter.ice
(using Ice Builder) and then compiles both gener at ed\ Pri nt er. cs and the default no-op Pr ogr am cs.
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0 He it View Gt Pojt Buld Dobug lest Amyze ook btensions Window Help | O Seach+  printer ® - o
(©-0|B-2BB| 9| Jwe e Ibsm-b G- |m|E i RAAW, 4 oS
Prntercs 6 = o
 ciont ] bemoprmer 1 1+
1 =// o J
2 // Copyright (c) ZeroC, Inc. All rights reserved.
3 1/
4 /7
5 // Ice version 3.7.10
6 1/
7 // <auto-generated>
8 // o
9 // Generated from file "Printer.ice’
10 1/
11 // Warning: do not edit this file.
12 1/
13 // </auto-generated> Aa: i
14 1/
15
16
17 using _System = global::System;
18
19 #pragma warning disable 1591
20
21 [=Inamespace Demo
22
23 [global::System.Runtime.InteropServices.ComVisible(false)]
24 [global: :System.Diagnostics.CodeAnalysis.SuppressMessage("Microsoft.Naming", "CA1704")]
25 [global: :System.Diagnostics.CodeAnalysis.SuppressMessage("Microsoft.Naming", "CA1707")]
26 [global::System.Diagnostics.CodeAnalysis.Suppressiessage("Microsoft.Naming”, "CA1769")]
27 [global: :System.Diagnostics.CodeAnalysis.Suppressiessage("Microsoft.Naming", "CA1716")]
28 [global: :System.Diagnostics.CodeAnalysis.SuppressMessage("Microsoft.Naming CA1711")]
29 [global::System.Diagnostics.CodeAnalysis.SuppressMessage("Microsoft.Naming", "CA1715")]
30 [global: :System.Diagnostics.CodeAnalysis.SuppressMessage("Microsoft.Naming", "CA1716")]
31 [global: :System.Diagnostics.CodeAnalysis.SuppressMessage("Microsoft.Naming", "CA1720")]
32 [global::System.Diagnostics.CodeAnalysis.Suppressiessage("Microsoft.Naming”, "CA1722")]
33 [global: :System.Diagnostics.CodeAnalysis.Suppressiessage( "Microsoft.Naming”, "CA1724")]
2 refer 10 changes | 0 authors, 0 changes I .
E ) i ca sc cur

Output

@ Ice Builder invokes the Slice to C# compiler (sl i ce2cs) to compile Slice files into C# files.

.NET 6.0
Add a Slice item that includes Pri nt er . i ce to your two projects. The code below shows the client project:

Client.csproj

<?xm version="1.0" encodi ng="utf-8"?>
<Proj ect Sdk="M crosoft.NET. Sdk" >
<Pr opertyG oup>
<Cut put Type>Exe</ Qut put Type>
<Tar get Fr anewor k>net 6. 0</ Tar get Fr amewor k>
</ PropertyG oup>
<|tenG oup>
<SliceCompile Include="../Printer.ice" />
<PackageRef erence I nclude="zeroc.ice.net" Version="3.7.8" />
<PackageRef erence | ncl ude="zeroc.icebuilder.nsbuild" Version="5.0.9" />
</|tenoup>
</ Proj ect >

When building the project, the Sl i ceConpi | e task (imported automatically from the zer oc. i cebui | der. nsbui | d NuGet package) compiles Pr i
nter.iceintogenerated/ Printer.cs using the Slice to C# compiler, slice2cs.

Use the following command to build the projects:

dotnet build Server
dotnet build dient
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Write and Compile your Server

To implement our Pri nt er interface, we must create a servant class. By convention, a servant class uses the name of its interface with an | -suffix,
so our servant class is called Pri nt er | and we will place it into the default C# source file Program.cs:

C#

using System

nanespace Server

{
public class Printerl : Deno.PrinterDisp_
{
public override void printString(string s, Ice.Current current)
{
Consol e. Wi teLine(s);
}
}
class Program
{
static void Main(string[] args)
{
}
}
}

The Printer| class inherits from a base class called Pri nt er Di sp_, which is generated by the sl i ce2cs compiler. The base class is abstract
and contains a pri nt St ri ng method that accepts a string for the printer to print and a parameter of type | ce. Cur r ent . (For now we will ignore the
I ce. Current parameter.) Our implementation of the pri nt St r i ng method simply writes its argument to the terminal.

The remainder of the server code follows in Pr ogr am cs and is shown in full here:
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usi ng System

nanespace Server

{

public class Printerl : Denp.PrinterDisp_
{
public override void printString(string s, Ice.Current current)
{
Consol e. Wi teLine(s);
}
}
public class Program
{
public static int Main(string[] args)
{
try
{
usi ng(l ce. Conmuni cator communi cator = lce.UWil.initialize(ref args))
{

var adapter =
conmmuni cat or . cr eat eObj ect Adapt er Wt hEndpoi nts(" Si npl ePrinter Adapter", "default -h

| ocal host -p 10000");

adapter.add(new Printerl (), Ice.Uil.stringToldentity("SinmplePrinter"));
adapter. activate();
conmmuni cat or . wai t For Shut down() ;
}
}
cat ch(Exception e)
{
Consol e. Error. WiteLine(e);
return 1;

}

return O;

The body of Mai n contains a t ry block in which we place all the server code, followed by a cat ch block. The catch block catches all exceptions that
may be thrown by the code; the intent is that, if the code encounters an unexpected run-time exception anywhere, the stack is unwound all the way
back to Mai n, which prints the exception and then returns failure to the operating system.

Thelc

e. Conmuni cat or object implements | Di sposabl e, which allows us to use the usi ng statement for the initialization of the | ce.

Conmmruni cat or object. This ensures the communicator dest r oy method is called when the usi ng block goes out of scope. Doing this is essential
in order to correctly finalize the Ice run time.

The body of our t ry block contains the actual server code.

The code goes through the following steps:

1.

We initialize the Ice run time by calling I ce. Util.initialize.(We pass ar gs to this call because the server may have command-line
arguments that are of interest to the run time; for this example, the server does not require any command-line arguments.) The calltoi ni ti
al i ze returns an | ce. Conmuni cat or reference, which is the main object in the Ice run time.

. We create an object adapter by calling cr eat eObj ect Adapt er W t hEndpoi nt s on the Conmruni cat or instance. The arguments we
pass are " Si npl ePri nt er Adapt er" (which is the name of the adapter) and " def aul t -p 10000", which instructs the adapter to listen
for incoming requests using the default transport protocol (TCP/IP) at port number 10000.

. At this point, the server-side run time is initialized and we create a servant for our Pri nt er interface by instantiating a Pri nt er | object.

. We inform the object adapter of the presence of a new servant by calling add on the adapter; the arguments to add are the servant we have
just instantiated, plus an identifier. In this case, the string " Si npl ePri nt er" is the name of the Ice object. (If we had multiple printers,
each would have a different name or, more correctly, a different object identity.)

. Next, we activate the adapter by calling its act i vat e method. (The adapter is initially created in a holding state; this is useful if we have

many servants that share the same adapter and do not want requests to be processed until after all the servants have been instantiated.)

. Finally, we call wai t For Shut down. This call suspends the calling thread until the server implementation terminates, either by making a call

to shut down the run time, or in response to a signal. (For now, we will simply interrupt the server on the command line when we no longer
need it.)
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We can compile the server code as follows:

.NET Framework 4.5 with Visual Studio
Build the server project using "Build > Builder Server"

i.'ﬂ printer - Micresoft Visual Studio ¥ & | CQuickLaunch (Ctd+Q) P - O =
File Edit View Project | Build | Debug Team Tools Test Analyze Window Help Jose Gutierrez de la Concha =
i@-0 | @ -2 M & BuidSoluton Ctrl+Shift+B
Rebuild Selution

Solution Explorer > X
Clean Solution

B o cU
Run Code Analysis on Solution Alt+F11 o & ‘ @ (VI

Build Server Search Solution Explorer (Ctrl+;) P~

B Solution 'printer’ (2 projects)
4 Client
b J Properties
Publish Server b =B References
Run Code Analysis on Server 4 generated
Batch Build... p_ C Printercs
¥ App.config
¥ packages.config
[% Printerice
©* Program.cs

Rebuild Server

Clean Server

¥0qiooy  12101dx3 1aNI3G

Configuration Manager...

J Properties

=8 References
generated

P ©* Printer.cs

¥ App.config

¥ packages.config

[& Printerice

# Program.cs

Show output from: | Build

[ Output Solution Explorer [REETRNSTINE

[ This item does not support previewing #4 Add to Source Control «

.NET 6.0
Build the server project using the dotnet bui | d command:

cd Server
dotnet build

Write and Compile your Client

The client code, in Cl i ent/ Progr am cs, looks very similar to the server.

Here it is in full:
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C#

usi ng Denv;
using System

nanespace Cient

{ public class Program
{ public static int Main(string[] args)
{
try
{
usi ng( | ce. Conmuni cat or comuni cator = lce.Wil.initialize(ref args))
{ var obj = communicator.stringToProxy("Si nplePrinter:default -h |ocal host -p 10000");
var printer = PrinterPrxHel per.checkedCast (obj);
if(printer == null)
{ throw new Applicati onException("lInvalid proxy");
}
printer.printString("Hello Wrld!'");
}
}
cat ch( Exception e)
{ Consol e. Error. WiteLine(e);
return 1;
}
return O;
}
}
}

Note that the overall code layout is the same as for the server: we use the same t ry and cat ch blocks to deal with errors. The code inthe try
block does the following:

1. As for the server, we initialize the Ice run time by calling | ce. Uti | . i ni tial i ze within the usi ng statement

2. The next step is to obtain a proxy for the remote printer. We create a proxy by calling st ri ngToPr oxy on the communicator, with the string
"Sinmpl ePrinter:default -p 10000". Note that the string contains the object identity and the port number that were used by the
server. (Obviously, hard-coding object identities and port numbers into our applications is a bad idea, but it will do for now; we will see more
architecturally sound ways of doing this when we discuss IceGrid.

3. The proxy returned by st ri ngToPr oxy is of type | ce. Obj ect Pr x, which is at the root of the inheritance tree for interfaces and classes.
But to actually talk to our printer, we need a proxy for a Pri nt er interface, not an Obj ect interface. To do this, we need to do a down-cast
by calling Pri nt er Pr xHel per . checkedCast . A checked cast sends a message to the server, effectively asking "is this a proxy for a Pr i
nt er interface?" If so, the call returns a proxy of type Denp: : Pri nt er ; otherwise, if the proxy denotes an interface of some other type, the
call returns null.

4. We test that the down-cast succeeded and, if not, throw an error message that terminates the client.

5. We now have a live proxy in our address space and can call the pri nt St ri ng method, passing it the time-honored "Hel | o Wor | d!"
string. The server prints that string on its terminal.

The client's project is just like the server's project shown earlier.

.NET Framework 4.5 with Visual Studio
Build the client project using "Build > Builder Client"
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)| printer - Microsoft Visual Studio ¥ & | QuickLaunch (Cti+Q) P - o x
File Edit View Project | Build | Debug Team Tools Test Analyze Window Help Jose Gutierrez de la Concha =
i@-0 | @ -2 M & BuidSoluton Ctrl+Shift+B - P St | g

Rebuild Selution
Solution Explorer

Clean Solution : - :
= = el

Run Code Analysis on Solution Alt+F11 o & ‘ C] G a

Build Client Search Solution Explorer (Ctrl+;) P~

Rebuild Client =l Sﬂ\utl.nn printer' (2 projects)
4 Client
b J Properties
Publish Client b =B References
Run Code Analysis on Client 4 generated

Clean Client

%0qiooy  i3101dx3 1aNI3S

Batch Build... b F'rmte.r‘:s
¥ App.config
¥ packages.config
[% Printerice
P ©* Program.cs
rl Server
b M Properties
P =B References
4 generated
P ©* Printer.cs
¥ App.config
) packages.config
[% Printerice
# Program.cs

Configuration Manager...

Output

Show output from: | Build

Error List [KeliiIl4 Solution Explorer [Ty RSV

A Add to Source Control =

.NET 6.0
Build the client project using dotnet bui | d command:

cd dient
dotnet build

Run your Client and Server

To run client and server, we first start the server in a separate window:

.NET Framework 4.5

server

.NET 6.0

cd Server
dotnet run

At this point, we won't see anything because the server simply waits for a client to connect to it. We run the client in a different window:

.NET Framework 4.5
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client

.NET 6.0

cd dient
dotnet run

The client runs and exits without producing any output; however, in the server window, we see the "Hel | o Wor | d! " that is produced by the printer.
To get rid of the server, we just interrupt it on the command line for now.

If anything goes wrong, the client will print an error message. For example, if we run the client without having first started the server, we get
something like the following:

I ce. Connect i onRef usedExcepti on
error =0

See Also

Client-Side Slice-to-C-Sharp Mapping
Server-Side Slice-to-C-Sharp Mapping
The Current Object

IceGrid
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